Resolved
The issue has been fully resolved by Vodafone. We apologize for the inconvenience caused and appreciate your understanding. If you continue to experience any issues, please reach out to our support team.
Investigating
We recently had been notified by Vodafone about a temporary data degradation of their services last night
Vodafone has solved the issue in the meantime